Complete Kit v 0.6 Assembly Error

Hello,

Unfortunately there has been an assembly error on the v 0.6 complete kit. Wrong component has been installed for D5 and D6 on the RF board. Although same component is used for D1 as well, it is not critical to change it. But D5/D6 are part of the SWR/PWR bridge and it is important to install the correct component. Please check if your RF board looks like that:

And if yes, please drop me a mail with your postal address. I will send you the correct replacement parts, free of charge.

I am sorry for the trouble, it was my error causing wrong BOM file sent to the factory.

73, Chris

M0NKA

14 thoughts on “Complete Kit v 0.6 Assembly Error

  1. Dave Fifield

    Hi Chris,

    Just for your records, my recently purchased v0.6 RF board has the incorrect “M1” diodes on it in positions D5 and D6 too.

    I have sourced some of the proper Schottky diodes locally here in California to save you the bother replacing them.

    Thanks,
    Dave

    Reply
  2. Stefan Froehlich

    Hi Chris,

    I think my RF board has this problem,
    my adress :

    [edited out for privacy]

    Regards,
    Stefan DL5MID

    Reply
  3. Tim - VA3TMA

    What is the correct labeling of the diodes. My board appears to say X12 for both D5 and D6, is a bit hard to see as the labeling is very light.

    Reply
    1. m0nka Post author

      Hi Tim,

      There are three different correct and one wrong type you can have. The wrong ones are quite big for the footprint and have the distinct M1 marking.
      If you have more questions, drop me a mail, i will send you the pdfs of all of them.

      73

      Reply
  4. Joe - OE5JFE

    Hello Chris,

    I would like to purchase a MCHF COMPLETE KIT v 0.6 soon.
    Will this error be checked and corrected or will those replacement parts be added to new orders?

    Thx for this great project

    Reply
    1. m0nka Post author

      Hi Joe,

      Yes, since the problem was pointed out, i am replacing the diods myself before shipping.

      73

      Reply
  5. Hans Lammerts

    Hi Chris,

    I think my RF board has this problem, but before I send you an email, please let me get rid of a bit of confusion.
    On my board, D5 and D6 look exactly as shown in the picture.
    What would the picture be like if the problem is resolved ?
    Do I need to remove D5/D6 and replace them with something else (SMT soldering ?)

    Regards,
    Hans

    Reply
    1. m0nka Post author

      Hi Hans,

      If your diods are much bigger than the footprint on the board and have the M1 marking, they are wrong for sure. I will send you correct parts and you just need to replace them.

      73

      Reply
      1. Hans Lammerts

        Ok Chris,

        Very, very little experience with SMD soldering, but I’ll give it a try. I hope that the kathode marking on the new diodes will be visible as clear as on the wrong ones.
        You obviuosly have my email. I take it, looking at your response, you still have my home address in your records ?

        Thanks,
        Hans

        Reply

Leave a Reply

Your email address will not be published. Required fields are marked *